Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Tim Offline
#1 Posted : Sunday, September 25, 2011 7:39:59 PM(UTC)
Tim
Private
Joined: 9/25/2011(UTC)
Posts: 6

Hello,
I was hugely excited about this mod, and on the one occasion I got it to work it was absolutely spectacular. As you can probably guess from that sentence, getting it to work is something of a problem. I'm using windows xp, and have a copy of RA3 on steam, patched up to 1.12. The problem is that I run the icon, the RA3 banner comes up on the desktop, hangs for a few seconds, then nothing happens. RA3 doesn't actually run, nor does the mod. The installer puts the mod files in my documents/Red Alert 3/mods, and this did not work. I read that for the steam client version that the files needed to be in the steamapps/common/RA3/Mods file, but when I moved the files there manually that didn't work either. The one time that it worked seemed quite random. I hadn't changed anything, and was just spamming the shortcut hoping it would work, and it did, just once, and it worked flawlessly. My copy of RA3 runs perfectly otherwise

So, does anybody have any idea what is going on? If more details are needed about my pc, do ask.
Thank you for making this mod, what of it I could access was immensely enjoyable.
Sponsor
KatzSmile Offline
#2 Posted : Sunday, September 25, 2011 8:55:43 PM(UTC)
KatzSmile
Private
Joined: 9/22/2011(UTC)
Posts: 3
Location: Russia

try make a link for ra3.exe and add to his target path '-ui'

example:
"C:\Program Files\Steam\steamapps\common\RA3\ra3.exe" -ui

save it and run.
in opened window choose Games and select mods tabs. Choose The Red Alert mod and play it
Tim Offline
#3 Posted : Sunday, September 25, 2011 9:38:14 PM(UTC)
Tim
Private
Joined: 9/25/2011(UTC)
Posts: 6

Hello Katz,

I tried this, and it had no effect. In the ui, I find the game browser, and mod tab. This tab has the TheRedAlert 1.0, and when I use it the same thing happens. Steam launcher appears for a second, then disappears quickly, then RA3 banner appears on the desktop for 20 seconds, and then disappears. The game does not launch when I use the mod.
noodlesocks Offline
#4 Posted : Monday, September 26, 2011 5:03:13 AM(UTC)
noodlesocks
Private
Joined: 9/25/2011(UTC)
Posts: 2

If you moved the files you would have to change the shortcut to point to the new location.

When it does nothing, check task manager to see if anything is running.
Tim Offline
#5 Posted : Monday, September 26, 2011 6:21:01 AM(UTC)
Tim
Private
Joined: 9/25/2011(UTC)
Posts: 6

Hi Noodle,

Yes I changed the target and path of the shortcut when I moved the file. No effect. I bring up the task manager and under applications it's basically as expected. There is nothing running, then I start the mod, then the steam launcher appears (in task manager too), then RA3 banner on the desktop (this appears in task manager), this is on screen for about 5-15 seconds, then it goes away and nothing is running in task manager. Under processes RA3 isn't running after the banner.

So my next question here is: "Are the mod files supposed to be in under My Documents/Red Alert 3/Mods/TheRedAlertMod, or under Steam/SteamApps/CommandAndConquerRedAlert3/Mods/TheRedAlertMod?"

The installer automatically puts them in the first file, and it doesn't seem to work either way.
Tim Offline
#6 Posted : Monday, September 26, 2011 6:25:28 AM(UTC)
Tim
Private
Joined: 9/25/2011(UTC)
Posts: 6

I'm beginning to think this could be a steam issue, as the steam launcher usually takes about 20 seconds before the RA3 banner appears. With this mod the steam launcher is there for less than a second before disappearing. I can't remember, but the one time this mod worked, I think the steam launcher was there for the usual time.
Blbpaws Offline
#7 Posted : Monday, September 26, 2011 8:13:41 AM(UTC)
Blbpaws
Administrator
C&C Labs Staff: Labs Staff MemberThe Forgotten Staff: The Forgotten StaffRed Alert Staff: Red Alert Staff MemberAll Stars Staff: All Stars Staff
Joined: 1/1/2003(UTC)
Posts: 6,526
Location: USA

Thanks: 3 times
Was thanked: 48 time(s) in 33 post(s)
I don't have steam, but I don't think it matters where you put the files, so long as the config to them is correct. Someone at moddb suggested doing this:

Add -modconfig "C:\Users\USERNAME\Documents\Red Alert 3\Mods\TheRedAlert\config.txt" to your STEAM launch options replace the quoted part with your directory path. Worked great on windows 7, replacing the bit above to point to the correct directory.
Tim Offline
#8 Posted : Monday, September 26, 2011 6:55:02 PM(UTC)
Tim
Private
Joined: 9/25/2011(UTC)
Posts: 6

Thanks paws, that seems to have done the trick. Having changed the launch option makes it run the mod rather than the vanilla game. To change it back I'll just switch the launch option. Thanks to all who offered advice.
bigmoma35 Offline
#9 Posted : Wednesday, January 18, 2012 2:40:27 AM(UTC)
bigmoma35
Private
Joined: 1/18/2012(UTC)
Posts: 1

okey this message is for blbpaws i have the same problem as what you are saying i just don't get what you mean with :Add -modconfig "C:\Users\USERNAME\Documents\Red Alert 3\Mods\TheRedAlert\config.txt" to your STEAM launch options replace the quoted part with your directory path. Worked great on windows 7, replacing the bit above to point to the correct directory.can you explane me that a little better or we can talk over skype or something that would be easy to :)
Please reply
Blbpaws Offline
#10 Posted : Thursday, January 19, 2012 12:49:11 PM(UTC)
Blbpaws
Administrator
C&C Labs Staff: Labs Staff MemberThe Forgotten Staff: The Forgotten StaffRed Alert Staff: Red Alert Staff MemberAll Stars Staff: All Stars Staff
Joined: 1/1/2003(UTC)
Posts: 6,526
Location: USA

Thanks: 3 times
Was thanked: 48 time(s) in 33 post(s)
I believe the person who suggested that edited the target on the shortcut, probably by right clicking and going to properties, but I don't have steam so I'm not sure.
Bibber Offline
#11 Posted : Thursday, January 19, 2012 5:09:14 PM(UTC)
Bibber
Private
Joined: 10/1/2010(UTC)
Posts: 30
Germany

Was thanked: 7 time(s) in 4 post(s)
In the Library right-click the game -> Properties -> Tab "General" -> Set launch options...
Users browsing this topic
Guest (2)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF 1.9.6.1 | YAF © 2003-2020, Yet Another Forum.NET
This page was generated in 1.092 seconds.