Welcome Guest! To enable all features please Login. New Registrations are disabled.

Notification

Icon
Error

Nooboi Offline
#1 Posted : Tuesday, June 7, 2022 5:56:16 AM(UTC)
Nooboi
Private
Joined: 10/22/2021(UTC)
Posts: 22

Thanks: 6 times
so i was creating some new defences and decided that its many so i created a new commandset and seperate the defense buildings, BUT now the AI/bots are not building the defences anymore


same as goes with my new units and my edited marauder tank they are not building it.

how do i code it so that the bots does this things
Sponsor
UTD^Force Offline
#2 Posted : Wednesday, June 8, 2022 12:43:52 PM(UTC)
UTD^Force
Colonel
C&C Labs Staff: Labs Staff MemberMaps Staff: Maps Staff Member
Joined: 8/13/2013(UTC)
Posts: 833
Jordan
Location: Middle east

Thanks: 438 times
Was thanked: 171 time(s) in 155 post(s)
You will need to edit the scripts to make new scripts to order the AI to build the new units.
The scripts are found in the game's folder > data > scripts > SkirmishScripts.scb

They take some time to load into worldbuilder depending on your device.

I've never edited the AI to build new units but have you tried keeping the original commandbuttons/commansets and just let the AI build the new units through them? While keeping the original prerequisites, too.
Nooboi Offline
#3 Posted : Saturday, June 11, 2022 6:17:05 AM(UTC)
Nooboi
Private
Joined: 10/22/2021(UTC)
Posts: 22

Thanks: 6 times
Originally Posted by: UTD^Force Go to Quoted Post
You will need to edit the scripts to make new scripts to order the AI to build the new units.
The scripts are found in the game's folder > data > scripts > SkirmishScripts.scb

They take some time to load into worldbuilder depending on your device.

I've never edited the AI to build new units but have you tried keeping the original commandbuttons/commansets and just let the AI build the new units through them? While keeping the original prerequisites, too.


what file do you use to open skirmishScripts.scb?


and question: so if i like add New_ to the original units will it still work?

like: New_AmericaTankCrusader



UTD^Force Offline
#4 Posted : Sunday, June 12, 2022 10:25:11 AM(UTC)
UTD^Force
Colonel
C&C Labs Staff: Labs Staff MemberMaps Staff: Maps Staff Member
Joined: 8/13/2013(UTC)
Posts: 833
Jordan
Location: Middle east

Thanks: 438 times
Was thanked: 171 time(s) in 155 post(s)
You need to use worldbuilder program then import the scripts from the folder I mentioned above, after that you will need to go through the painful process of editing the scripts.

Or

What I mean was like make the new unit with the whole new code but call it 'AmericaTankCrusader' or another original tank's name that the AI would build, like that the AI should still use the old command buttons to build your new tank while it thinks it is the old AmericaTankCrusader as you would not have to change the commandsets/buttons. If you get what I mean.
Nooboi Offline
#5 Posted : Sunday, June 19, 2022 6:40:58 AM(UTC)
Nooboi
Private
Joined: 10/22/2021(UTC)
Posts: 22

Thanks: 6 times
Yea I got to be able for AI to build my custom tank of Tank General, by using the infernocannon's Commandbutton, Object Name

However what if I couldn't open world builder? is there a way to fix the worldbuilder error that it cannot find my units
UTD^Force Offline
#6 Posted : Sunday, June 19, 2022 6:59:53 AM(UTC)
UTD^Force
Colonel
C&C Labs Staff: Labs Staff MemberMaps Staff: Maps Staff Member
Joined: 8/13/2013(UTC)
Posts: 833
Jordan
Location: Middle east

Thanks: 438 times
Was thanked: 171 time(s) in 155 post(s)
Originally Posted by: Nooboi Go to Quoted Post
is there a way to fix the worldbuilder error that it cannot find my units


Do you mean that you don't find your units in the object lists?
If I remember correctly you won't have that problem as long as you have this part in your unit's code.

Code:

  EditorSorting       = VEHICLE
  Side                = America
Nooboi Offline
#7 Posted : Sunday, June 19, 2022 7:20:09 AM(UTC)
Nooboi
Private
Joined: 10/22/2021(UTC)
Posts: 22

Thanks: 6 times
No like the WorldBuilder crash its like "Runtime Error" and then it crashes

Edited by user Sunday, June 19, 2022 7:28:22 AM(UTC)  | Reason: typo

UTD^Force Offline
#8 Posted : Sunday, June 19, 2022 7:45:32 AM(UTC)
UTD^Force
Colonel
C&C Labs Staff: Labs Staff MemberMaps Staff: Maps Staff Member
Joined: 8/13/2013(UTC)
Posts: 833
Jordan
Location: Middle east

Thanks: 438 times
Was thanked: 171 time(s) in 155 post(s)
Originally Posted by: Nooboi Go to Quoted Post
No like the WorldBuilder crash its like "Runtime Error" and then it crashes


It's been a while since I worked on WB but is this the error where you can choose Abort Retry or Ignore?
If so just keep choosing ignore, if that's not it then maybe check the crash report for WB, there may be something wrong with the INI codes or data the WB needs for the game.
Nooboi Offline
#9 Posted : Monday, June 20, 2022 9:15:00 PM(UTC)
Nooboi
Private
Joined: 10/22/2021(UTC)
Posts: 22

Thanks: 6 times
i tried only picking "Retry" however it just very slow it loads 1 of those messages per 10 minutes, is this normal?
stevenmbrun
#10 Posted : Tuesday, June 21, 2022 5:42:56 AM(UTC)
Guest

Was thanked: 1 time(s) in 1 post(s)
Message was deleted by a Moderator. | Reason: Not specified
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF 1.9.6.1 | YAF © 2003-2022, Yet Another Forum.NET
This page was generated in 0.584 seconds.