Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

shahvand Offline
#1 Posted : Thursday, February 26, 2009 11:23:22 PM(UTC)
shahvand
Private
Joined: 2/26/2009(UTC)
Posts: 4

I got it when try to play LAN with my friends.

generals zero hour mismatch and synchronization error

please help me
Sponsor
krit Offline
#2 Posted : Friday, February 27, 2009 1:49:50 AM(UTC)
Krit
Commander in Chief
Joined: 4/15/2004(UTC)
Posts: 2,200
Location: Gensokyo

Was thanked: 11 time(s) in 10 post(s)
It's a common issue, happens all the time, unless you're playing with a mod on your game or your friend's game is modded, in which case removing the mod should solve the problem.

Edited by user Friday, February 27, 2009 1:51:01 AM(UTC)  | Reason: Not specified

paimail Offline
#3 Posted : Friday, February 27, 2009 3:49:57 AM(UTC)
paimail
Major
The Forgotten Staff: The Forgotten Staff
Joined: 3/2/2008(UTC)
Posts: 308
Location: Over there

yeah and it also occures if you have different versions of the game...
shahvand Offline
#4 Posted : Friday, February 27, 2009 3:53:36 AM(UTC)
shahvand
Private
Joined: 2/26/2009(UTC)
Posts: 4

krit Offline
#5 Posted : Friday, February 27, 2009 4:09:13 AM(UTC)
Krit
Commander in Chief
Joined: 4/15/2004(UTC)
Posts: 2,200
Location: Gensokyo

Was thanked: 11 time(s) in 10 post(s)
Have you patched the game up to the latest version on both of them?
shahvand Offline
#6 Posted : Friday, February 27, 2009 4:11:25 AM(UTC)
shahvand
Private
Joined: 2/26/2009(UTC)
Posts: 4

no patch

patched

tested

not worked

Edited by user Friday, February 27, 2009 4:11:58 AM(UTC)  | Reason: Not specified

krit Offline
#7 Posted : Friday, February 27, 2009 4:27:01 AM(UTC)
Krit
Commander in Chief
Joined: 4/15/2004(UTC)
Posts: 2,200
Location: Gensokyo

Was thanked: 11 time(s) in 10 post(s)
Hmm... Looks like one of the random ones than... Does this happen when you play online as well?
shahvand Offline
#8 Posted : Friday, February 27, 2009 9:25:58 PM(UTC)
shahvand
Private
Joined: 2/26/2009(UTC)
Posts: 4

no online Onlye playe in lan

map random ofthen is error
zergswarms Offline
#9 Posted : Saturday, February 28, 2009 6:01:01 AM(UTC)
ZergSwarms
Major
C&C Labs Staff: Labs Staff Member
Joined: 12/27/2007(UTC)
Posts: 339
Location: USA

How far into the game does the mismatch occur?
paimail Offline
#10 Posted : Saturday, February 28, 2009 4:27:13 PM(UTC)
paimail
Major
The Forgotten Staff: The Forgotten Staff
Joined: 3/2/2008(UTC)
Posts: 308
Location: Over there

Does both of you use the same key code?
if yes then uve gotten your prob right there
samu Offline
#11 Posted : Thursday, May 21, 2009 5:48:30 AM(UTC)
samu
Private
Joined: 5/21/2009(UTC)
Posts: 5
Location: Lithuania

shahvand wrote:


test ini/default/aidata
possibly if where are added any new skills
the creator of it placed science of the skill to ai.
replace aidata with original (not empty one :) )
hiro14 Offline
#12 Posted : Friday, May 17, 2013 11:10:52 PM(UTC)
Hiro14
Private
Joined: 5/17/2013(UTC)
Posts: 2

Use windows explorer to navigate to where you install directory is. Once there open up the "Data" folder. Then open up INI. You should have a file called GameData.ini Make sure this file is the same on all computers.

Next, open up My Documents and navigate to the "Command and Conquer Generals Zero Hour Data" folder. You should have a file called Options.ini. Open this file with a text editor and find the line that says "IPAddress = xxx.xxx.xxx.xxx" Make sure that the ip address reflects the ip address that your computer has. I am sure this was the primary cause of the mismatch.

Before you start up your game make sure to run it as administrator. Turn off any unused network cards to make sure the game doesn't try to use the wrong network card to communicate. Turn off Himachi and disable its virtual network card if you have one.

Run the game. It should work for you. I have shockwave mod 1.1 installed and it works fine over the network. The game does tend to go a bit slow when all players have tanks and units on the field. Hopefully this fixes your problem. It fixed mine.

Notes -
My setup was the following,
2 unique computers running different graphics cards
both had windows 7 x64 installed
C&C Generals Zero Hour patch 1.04 installed via The First Decade
Each computer had unique serial keys
Both computers were modded with the Shockwave Mod version 1.1
Highground Offline
#13 Posted : Sunday, June 16, 2013 3:20:07 AM(UTC)
Highground
Private
Joined: 6/16/2013(UTC)
Posts: 1
Hungary
Location: Budapest

Hi folks!

Is there any solution for play this game over hamachi(VLAN) with AI, without this "mismatch error"? We have tried with my brother, to play against AI in different ways like: 4vs4,3vs3 with different mods(schw,rotr,project raptor,contra,etc.) and vanilla. But this "mismatch error" occurs almost in every game, after various time. We have the same 1.04ZH patch, and the same crack. Unfortunately, i have a bad feeling that there is not any. Because we are downloaded this "project raptor 9.0" which is 3.2Gb, and includes everything you need(gen+zh+patches+crack+mod), and this mod produces the same "mismatch error" after a while. So is there any tested and working solution? Anything...

Thanks for the help in advance!
tts Offline
#14 Posted : Saturday, January 13, 2018 6:01:45 AM(UTC)
TTS
Private
Joined: 8/28/2017(UTC)
Posts: 1

I've been playing this game for a number of years most of time with Shockwave or Rise of the Red mods. The Mismatch synchronisation error pops up randomly in LAN game, I've tried tutorials people put up on youtube and there is no obvious solution to this matter.

I have recently got it working with game speed greatly improved. That is to run it on a delicate wireless router that's not connected to the internet. For majority of house holds that has one wireless router provides internet access, you can unplug the ADSL/NBN cable before starting the game. Or if you have an powerful phone with no sim card in it, use that as a router also works. I've run it on a secondary router for a number of times with each game lasts about an hour and the Mismatch synchronisation error did not pop.

I'm currently running the Origin Game version of Generals Zero hour with Shockwave or Rise of the red mod on three Win 10 HP I7 Laptops, we play with/against AI players most of times. You will need to make sure all computers has the identical copy of the game with Windows firewall privilege setup for General.exe.

Edited by user Thursday, January 18, 2018 8:05:55 PM(UTC)  | Reason: Not specified

Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF 1.9.6.1 | YAF © 2003-2018, Yet Another Forum.NET
This page was generated in 1.524 seconds.